added gentoo-ebuild
[public/dnssec-swede-utility.git] / swede-9999.ebuild
1 # Copyright 1999-2012 Gentoo Foundation
2 # Distributed under the terms of the GNU General Public License v2
3 # $Header: $
4
5 # This ebuild should reside in your local overlay in the net-dns category. 
6 # Please see http://en.gentoo-wiki.com/wiki/Overlay#Local_Overlays 
7 # for more information. 
8
9 # Please remember to run ebuild swede-9999.ebuild manifest after copying the file
10
11 EAPI=4
12 inherit eutils git
13 DESCRIPTION="Swede a utility to generate and test project DANE (TLSA) records."
14 HOMEPAGE="https://github.com/pieterlexis/swede"
15 EGIT_REPO_URI="git://github.com/pieterlexis/swede.git"
16
17 GIT_ECLASS=""
18 if [[ ${PV} == *9999* ]]; then
19         GIT_ECLASS="git" 
20 fi
21 LICENSE="GPL"
22 SLOT="0"
23 KEYWORDS="~amd64"
24 IUSE=""
25
26 # Python (>= 2.6)
27 # python-{unbound, argparse, ipaddr, m2crypto}
28 DEPEND="|| ( dev-lang/python:2.6 dev-lang/python:2.7 ) 
29                 net-dns/unbound[python] 
30                 dev-python/argparse
31                 dev-python/ipaddr
32                 dev-python/m2crypto"
33 RDEPEND="${RDEPEND}"
34
35 src_install() {
36         dobin swede
37         dodoc README
38
39         insinto /etc/swede
40         newins root.key root.key
41         newins dlv.isc.org.key dlv.isc.org.key
42 }